Menu

Can't compile prg:s with IAS

IotAppAccount
Joined
2017-01-18 17:54:24
Posts
15

Can't compile prg:s with IAS

My old PC broke and when I got a new PC ,platformio couldent compile if IAS was used, all other Esp programs works
So I have obviosly forgot something and installed Arduino ide and tried to compile VirginSoil example and got the same error: 

Arduino: 1.8.16 (Windows Store 1.8.51.0) (Windows 10), Board: "LOLIN(WEMOS) D1 R2 & mini, 80 MHz, Flash, Disabled (new aborts on oom), Disabled, All SSL ciphers (most compatible), 32KB cache + 32KB IRAM (balanced),
 Use pgm_read macros for IRAM/PROGMEM, 4MB (FS:2MB OTA:~1019KB), v2 Lower Memory, Disabled, None, Only Sketch, 921600"

C:\Users\BjornAdmin\Documents\Arduino\libraries\ESP-Library-master\src\espressif\esp8266\CallServer.cpp: In member function 'bool CallServer::get(const char*, String)':

C:\Users\BjornAdmin\Documents\Arduino\libraries\ESP-Library-master\src\espressif\esp8266\CallServer.cpp:182:35: error: 'class BearSSL::WiFiClientSecure' has no member named 'loadCACert'

  182 |                 if(!this->_client.loadCACert(file, file.size()) || file.size() == 0) {

      |                                   ^~~~~~~~~~

exit status 1

Error compiling for board LOLIN(WEMOS) D1 R2 & mini.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Can one of you experts tell me what I have missed / forgot to install?

BR Bjorn

thedude
Joined
2022-01-01 16:07:23
Posts
2

change the version of the arduino platform to 2.5

befiware
Joined
2022-02-23 13:22:02
Posts
1

I have the same error. Did you find any solution for this?

Redeque
Joined
2022-03-06 13:27:10
Posts
1

Have the same issue, can't get it to work.

IotAppAccount
Joined
2017-01-18 17:54:24
Posts
15

  Sorry I cant help took a pause from IOTAPPSTORY , I like the idea but as 74 year hobby programmer I have no practical use for OTA. Now I'm testing ESP and EasyCAT with a Beckhoff PLC 😹😹 TwinCAT 3